[WooreeINFO] MicroEJ Studio - ej.kf.IncompatibleFeatureException

Dear,

When i tried to deploy the sample application of ‘hello’ based on your instructions at the URL of http://developer.microej.com/getting-started-stm32f746-disco.html, i met the ‘FAIL’ condition as you can see in the screen shot in the attachment.

Actually i see the application downloaded from your online store, installed and running without a problem on my device, STM32F746G-DISCO.

Please advise me where i have missed anything while i am getting more accustomed to the MicroEJ Studio based on reading and understanding “Create your First MicroEJ Application”.

Thanks much in advance for your cooperation.
YH Kwon

IncompatibleFeatureException

Dear @kwonyh,

IncompatibleFeatureException occurs when a feature is tried to be installed in a Firmware which is not compatible with the Virtual Device used to build it.

Can you check that the Platform version in your Run Configuration is the same as the Firmware that you flashed on the board (same board, same flavor, same version) ?

Regards,

Dear Pierre Rivron,

i’d like to appreciate you for the quick feedback on this first of all, and please be noted with two screen shots, one for ‘run configurations’ of MicroEJ Studio and one for ‘compare’ of STM32 ST-LINK Utility as in the attachment, that both the virtual machine and the device firmware are matching to my device, STM32F746G-DISCO, as i think.

Actually this is what i did based on all the detailed steps in your ‘start-up guide’ webpage. Could you please advise me, then, where should i check and/or validate so as to solve this problem?

Thanks much in advance.

Regards
YH Kwon

(YH%4002192019)MicroEJ%20Developer%20Forum%20-%20attachment

dear @kwonyh,

I did the full process without issue. Unfortunatly your screenshots are too small for me to read them. Can you:

  1. In your board, launch the settings, scroll down to Firmware Version and make sure it is 1.11.4
  2. In the second page on your screenshot, that the platform is “VDE-YELLOW-STM32F746GDISCO-8SG7V (1.11.4)”.

Regards,

Dear Pierre Rivron,

Thanks a lot for your assistance here, and i found out this morning where my fault was located - based on your comments last night.

Please find the photo taken for the settings on my device in the attachment; where you can see the firmware version of 1.11.4.

My fault was that i imported the virtual device with its version of 1.13.0; which was downloaded from your website as well, but i can’t remember exactly where it was.

So i downloaded the correct virtual device with its version of 1.11.4 and tried running the sample application of ‘hello’ - actually a slightly modified version; which works now.

Even the sample service application of hello as in your user manual works, too.

i would like to appreciate you so much once again on your great assistance.

Regards
YH Kwon

(YH%4002202019)Firmware%20Version%20on%20device