Virtual devices dont show

I create a standalone project .when I run microej application

the virtual devices can not show out.Is my local configuration missing。

how can I make it run on virtual devices.


What are you trying to do? Are you trying to launch the Widget Demo or your simple Standalone application?

On which VEE Port are you trying to launch your MicroEJ Application?

If needed, you can follow our Getting Started available on our website: Get Started - Create Apps and Build a VEE Port - MicroEJ Technology. It shows how to launch your first MicroEJ Application and provides you some examples.

Best regards,

I run the demo_widget success,and then I create my own project ,
then I want to run it shows this

and it shows nothing

Do you have any errors on your Console logs?
What is the version of your MicroEJ SDK, to check if you got the last version you can click on Help > Check for Updates.

I try to reproduce what you have done on my side:

  • I create a new Standalone Application
  • I copy/paste the following package from the demo widget application:
  • To resolve the errors:
    • I updated the dependencies in the module.ivy file
    • In I have commented all pages except ProgressBarPage().

At this point at thinks that I am at the same point than you. When I launch the Standalone Application, I got an error because I did not add the resources of the Widget Demo to my new project.
Once I add them, it was working and I could launch my application, the Virtual Device appears with only the ProgressBar page.


this is my console logs:
the MicroEJ SDK version is 21.11.

=============== [ Initialization Stage ] ===============
=============== [ Converting fonts ] ===============
=============== [ Converting images ] ===============
=============== [ Launching on Simulator ] ===============
Exception in thread “bootstrap” (id=255): java.lang.ExceptionInInitializerError: java.lang.RuntimeException
at java.lang.Throwable.fillInStackTrace(
at java.lang.Throwable.(
at java.lang.Exception.(
at java.lang.RuntimeException.(
at ej.bon.Constants.getBoolean(
at java.lang.System.getProperty(
at java.lang.System.getProperty(
at java.lang.System.(
at java.lang.AbstractStringBuilder._append(
at java.lang.AbstractStringBuilder._append(
at java.lang.StringBuilder.(
at java.lang.Class.desiredAssertionStatus(
at java.lang.StackOverflowError.(
=============== [ Completed Successfully ] ===============


On which VEE Port are you trying to launch your application? Which version?

I use the VEE is VEEPort-STMicroelectronics-STM32F7508-DK-1.5.0.

If you create a simple HelloWorld application and try to run it on the Simulator does it works ?

To do so,

  • create a new Standalone Application in your SDK (File > New > Standalone Application).
  • Right click on this app and select (Run as > MicroEJ Application)
  • In the pop-up menus, select your VEE Port
  • A Hello World! message should appear in your Console logs.

hello word is appear in Console logs. but I want it appear in the virtual devices.

Can you contact us through our contact form here : Contact Us - MicroEJ
It will be easier to help you.
It seems that it could be an error from your launcher configurations.

when I try to contact you ,it show like this! Dose it any other way to contact you.

I sent you a private message about your issue the 01/13/2023. Maybe you haven’t seen it.
Best regards