Trying out the Mock Simulator unsuccessfully

I’ve been trying to use the Mock-Get-Started How-To example but after following the steps on the readme file I didn’t get anything different, not even an error message I also tried to print some debugs messages on MySNI and MyMockFrame and running the simulator with the verbose option, same result: nothing on the output from running the simulator.
Worth mentioning:

  • on the output I got from using verbose I could see that it was building the mockmock.jar file, which is the jar file built by the example;
  • I also updated the dependencies on module.ivy(bon and edc).

Hi @ricardobna,

What platform are you using? I tested this example with the platform available here: Get Started - Embedded Platform Development on STM32F746G-DISCO

Because on this platform I did not have to change any module dependency. I had to comment the ShieldedPlug use (that this platform cannot use in this version) in both the mock and the application but it runs properly after that.

Best Regards,
Gaëtan for MicroEJ

Hi @gaetan.harel I’m using STM32F7508

The platform STM32F7508 is not compatible with this example, the example will only work with UI2 platforms, the STM32F7508 one is using the latest UI3 libraries.