SDK License Key not found on MAC

sdk
#1

Hello,

I have the latest SDK version (4.1.5.) installed on a MacBook Pro. I have installed my architecture, but the license dongle is not recognized. Under preferences->MicroEJ, there is no license information. The dongle does work under linux and it also works on the Windows10 VM running on the same Mac.

Is there an additional step or driver that needs to be installed for Mac?

MacBook Pro 15’ running MacOS 10.14.3 Mojave.
License key connected through a USB-C adapter (USB 3.1 port).

Thanks,
Mike

#2

Hello Mike,

I assume that your Windows 10 VM is stopped to avoid it to preempt the dongle. (A restart may also prove to be useful.)

Can you run ioreg -p IOUSB in a terminal and ensure that the dongle is detected (something like HID Dongle@1a126000)?

What architectures are installed in your SDK? The dongle will not be detected with evaluation versions.

It works without any particular configuration on my computer. I have an older machine with only USB 2.0 ports and an older version of MacOS X (High Sierra 10.13.2). Have you tried on a USB 2.0 port (even though it would be odd because it is currently detected in the VM)?

Sébastien

#3

Hi Sebastien,

Yes, the VM is not running when I am trying to use the dongle on Mac. I ran the ioreg command and got this response:

HID Dongle@14340000 <class AppleUSBDevice, id 0x100002d53, registered, matched, active, busy 0 (2 ms), retain 14>

The architecture is ARM Cortex-A7 GCC 7.4.0 and does work just fine on other platforms.

My USB C adapters all support USB 3.x, I tried using a USB 2.0 HUB on the adapter and the ioreg command still sees the dongle, but the SDK does not.

Mike

#4

Hi Mike,

I will try to reproduce your environment and the issue.
Can you tell me:

  • Which VM you are using (Virtualbox, Parallels, etc.)? and what version?
  • Which Java (java -version in a terminal)?

Sébastien

#5

Hi Sebastien,

Java version is as follows:
java version “1.8.0_201”
Java™ SE Runtime Environment (build 1.8.0_201-b09)
Java HotSpot™ 64-Bit Server VM (build 25.201-b09, mixed mode)

I am using VMware Fusion for the Windows VM on Mac, but I have also been able to make it work using the same Windows 10 image on Virtualbox.

Just to clarify, this is running native on the Mac that does not work. I did have an issue with pointing the SDK installer to the Java install path during installation. I had to go edit the java install path in info.plist after the fact. Maybe that has something to do with it.

While you look at it, I will uninstall and reinstall the SDK.

Thanks,
Mike

#6

Hi @mcranston,

We just tested MicroEJ SDK with a production Platform on a freshly installed MacOS 10.14 Mojave. We can confirm the dongle is not recognized on this version (it works fine on MacOS 10.13 High Sierra, which is @sebastien.eon environment).

We have to make few additional tests. Maybe we will have to request support from our hardware dongle provider.

Sorry for the inconvenience. I will let you informed.

–Frédéric

#7

Hi @mcranston,

We received a new software update from our hardware dongle provider.

I can confirm this update fixes the issue (tested on both Mac OS 10.13 and Mac OS 10.14).

The fix has been integrated to main stream MicroEJ Architectures.

Please contact your customer care representative for more information about the availability.

–Frédéric

#8

Thank you! I will contact our account manager to get our platform architecture updated.