PQT and java.security.properties


I try to compile a PQT (core) using mmm

I define
-Dlaunch.properties.jvm=“-Djava.security.properties=PATH/javasec.prop” \

like in
cd YYY/nxpvee-mimxrt1170-evk-validation/core/java-testsuite-runner-core ; /home/nxf98634/buildkit/bin/mmm publish

but I get

[testsuite:javaTestsuite] [soar] 1 : SOAR ERROR
[testsuite:javaTestsuite] [soar] [M65] - License check failed [tampered (3)].

I tried to to put the line in the module.ivy but that did not work either

This workaround works OK for the app

The only way to make this work I found is to modify the sec file in the java installation

What am I missing?

Thanks a lot


Hello Guido,

This error occurs with JDK versions more recent than 8u351.

You can find more details and workarounds here License check fail workaround on MicroEJ SDK with JDK version 8u351.




this line comes from your link

but does not work in validation case

That is the issue


Hi Guido,
Ok, sorry for the misunderstanding.

I am not sure and it has not been verified but could you try to add the following prefix to your property: microej.testsuite.properties.. This piece of documentation explains how to inject Application build options to a testsuite: Module Natures — MicroEJ Documentation

I did not test on my side so there is 3 possibilities to try:

  1. -Dmicroej.testsuite.properties.launch.properties.jvm=“-Djava.security.properties=javasec.prop”
  2. -Dlaunch.properties.jvm=“-Dmicroej.testsuite.properties.java.security.properties=javasec.prop”
  3. -Dmicroej.testsuite.properties.launch.properties.jvm=“-Dmicroej.testsuite.properties.java.security.properties=javasec.prop”

Hope it will help you,


Hello Corentin,

Unfortunately neither works: I tried them separately and all together
but I always get the same error: “Tampered …”

I am sure about the path as the app ( not the test) compiles fine with it

Would you be so kind to test it on your side?

Thanks a lot!


Hello Guido,

I will try to reproduce your issue on my side.

Have a good day,

Hello Guido,

I managed to reproduce on my side. The fact is that the testsuite are not testsuite are not working the same way than an application when we use Build Module.

So this is not the same property that you have to set. Add the following property to the module.ivy file:

  • <ea:property name="microej.testsuite.jvmArgs" value="-Djava.security.properties=<path_to>/microej.jdk.security"/>

In the same time, you must check that the microej.testsuite.jvmArgs is not already set in your config (e.g. in config.properties file). If the property is already set, keep only the line above. The reason is that we found that we can only pass one argument to microej.testsuite.jvmArgs.

Have a good day,


Thanks a lot

That works for me