[Install] "Failed to load the JNI shared library" error on startup


#1

If you are getting that error message, it is most likely that you are running a 64 bits edition of MicroEJ on top of a 32 bits JVM (or the other way round).

You have to ensure that you are either :

  • running a 64bits version of MicroEJ with a 64bits JVM
  • running a 32bits version of MicroEJ with a 32bits JVM

You may select a different version of MicroEJ from the download page by clicking on the Other platforms hyperlink in the Download MicroEJ SDK|Studio step of

You may check which version of Java environment is run by default on your machine by running the following command in a DOS prompt

java -version

The line related to the VM shall specify 64-bit for relevant VMs

If you have many JRE/JDKs installed on your machine and do not or cannot have a JRE/JDK reachable via the PATH environment variable, you may force MicroEJ to use a specific JRE/JDK (matching the version of MicroEJ) by adding the following arguments to the beginning of the MicroEJ initialization file

-vm
C:\Program Files\Java\ <JRE_or_JDK_Location>\bin

Replacing the <JRE_or_JDK_Location> token by the one matching your actual installation

If there is no vm parameter in the MicroEJ .ini file, the JVM reachable via the PATH environment variable will be used (if any).